EDAboard.com | EDAboard.de | EDAboard.co.uk | WTWH Media

OT: Anyone remember this vintage audio amp?

Ask a question - edaboard.com

elektroda.net NewsGroups Forum Index - Repair Electronics - OT: Anyone remember this vintage audio amp?

Goto page 1, 2  Next

Chris
Guest

Sat Nov 09, 2019 11:45 am   



Hi all,

Without venturing into 'stupid money territory' the best quality audio by
far I've ever heard came from one particular solid state stereo amplifier
I'd be interested in re-acquainting myself with. Unfortunately I can't
recall the make or model number which is obviously a big barrier to the
desired reunion. However, if I mention some scant details I *do* remember
about it, maybe it will jog someone's memory.
What I _do_ recall is the following:-

It wasn't a Technics branded amp but neither was it one of the budget
brands.
It wasn't of European manufacture (I'm pretty sure it was Japanese).
It was the standard "separates" size of the late eighties/early nineties
and I owned one briefly 16 years ago so it can't be any later than 2003
and probably much earlier.
It had an all black finish.
It was only 60W per channel but punched above its weight in this respect
and produced _the_ most outstanding sound quality.
It was massively heavy on one side so must have had a _very_ substantial
transformer for such a relatively low power amp.
It had an unusual (and very cool) feature I'd never seen before or since
which hopefully will identify it: a quite small volume knob with a little
red LED on one edge of it which lit-up and physically rotated whenever
the remote control unit's volume button was activated.

Does that ring any bells with anyone? I wouldn't mind trying to find
another one!


Guest

Sat Nov 09, 2019 12:45 pm   



In sci.electronics.repair Chris <cbx_at_noreply.com> wrote:

Quote:
It wasn't a Technics branded amp but neither was it one of the budget
brands.
It wasn't of European manufacture (I'm pretty sure it was Japanese).
It was the standard "separates" size of the late eighties/early nineties
and I owned one briefly 16 years ago so it can't be any later than 2003
and probably much earlier.
It had an all black finish.
It was only 60W per channel but punched above its weight in this respect
and produced _the_ most outstanding sound quality.
It was massively heavy on one side so must have had a _very_ substantial
transformer for such a relatively low power amp.
It had an unusual (and very cool) feature I'd never seen before or since
which hopefully will identify it: a quite small volume knob with a little
red LED on one edge of it which lit-up and physically rotated whenever
the remote control unit's volume button was activated.


Pretty vague.

There were probably other companies but Yamaha had several in the "Natural
Sound" series (that name is probably generic) that had motor driven
mechanical remote-controled volume controls.

They also were lopsided with weight balance.

"produced _the_ most outstanding sound quality" is subjective and could
apply to 1000's of receivers along with the power rating.

Thats the best I can come up with.

-bruce
bje_at_ripco.com

John-Del
Guest

Sat Nov 09, 2019 12:45 pm   



On Saturday, November 9, 2019 at 4:51:34 AM UTC-5, Chris wrote:
Quote:
Hi all,

Without venturing into 'stupid money territory' the best quality audio by
far I've ever heard came from one particular solid state stereo amplifier
I'd be interested in re-acquainting myself with. Unfortunately I can't
recall the make or model number which is obviously a big barrier to the
desired reunion. However, if I mention some scant details I *do* remember
about it, maybe it will jog someone's memory.
What I _do_ recall is the following:-


It had an all black finish.


Well, most receivers and separate amplifiers of the 90s through the 2000s were black, so that's not much help...


Quote:
It was massively heavy on one side so must have had a _very_ substantial
transformer for such a relatively low power amp.


All receivers/amplifiers from that era had a 50/60hz power transformer, which meant weight. Every one I've ever worked on had the transformer mounted on one side, so any receiver of that era would list one way or the other.


Quote:
It had an unusual (and very cool) feature I'd never seen before or since
which hopefully will identify it: a quite small volume knob with a little
red LED on one edge of it which lit-up and physically rotated whenever
the remote control unit's volume button was activated.


There were several receivers/amplifiers that were remote controlled had the same feature. I remember some Sonys, Luxmans,

Quote:
Does that ring any bells with anyone? I wouldn't mind trying to find
another one!


What pops in my head is Yamaha or Denon. They made a lot of relatively lowered powered receivers and amps during those years, and they sounded pretty good, but I don't recall any real standouts in sound quality in the typical consumer level of components. The Luxman would be the best sounding I guess but they were more money. I wonder if the sound you remember was more a function of the speakers you used with the amp, not the amp itself.

But I've seen a Sonys, Pioneers, JVC, Technics, Onkyo, etc. with all black cabinets, heavy on one side, and a probably a red LED in the motorized volume control.

Mike Coon
Guest

Sat Nov 09, 2019 12:45 pm   



In article <qq6273$bug$1_at_dont-email.me>, cbx_at_noreply.com says...
Quote:

Hi all,

Without venturing into 'stupid money territory' the best quality audio by
far I've ever heard came from one particular solid state stereo amplifier
I'd be interested in re-acquainting myself with. Unfortunately I can't
recall the make or model number which is obviously a big barrier to the
desired reunion. However, if I mention some scant details I *do* remember
about it, maybe it will jog someone's memory.
What I _do_ recall is the following:-

It wasn't a Technics branded amp but neither was it one of the budget
brands.
It wasn't of European manufacture (I'm pretty sure it was Japanese).
It was the standard "separates" size of the late eighties/early nineties
and I owned one briefly 16 years ago so it can't be any later than 2003
and probably much earlier.
It had an all black finish.
It was only 60W per channel but punched above its weight in this respect
and produced _the_ most outstanding sound quality.
It was massively heavy on one side so must have had a _very_ substantial
transformer for such a relatively low power amp.
It had an unusual (and very cool) feature I'd never seen before or since
which hopefully will identify it: a quite small volume knob with a little
red LED on one edge of it which lit-up and physically rotated whenever
the remote control unit's volume button was activated.

Does that ring any bells with anyone? I wouldn't mind trying to find
another one!


I still have my JVC amp/receiver/cassette with rotating & flashing
volume control. But clearly not the same as your recollection!

Mike.

Phil Allison
Guest

Sat Nov 09, 2019 12:45 pm   



Chris wrote:

> Hi all,

( bloody cross poster !!)


From sci.electronics.design:


** Might it be a Proton AM30 or similar ??

https://archiwum.allegro.pl/oferta/integrated-amplifier-proton-am-30-2x80w-better-nad-i7105457465.html

Lotsa weight on LH side, 80wpc, all black, simple, very good specs and almost a top name brand.


..... Phil

Al
Guest

Sat Nov 09, 2019 1:45 pm   



On Sat, 09 Nov 2019 11:01:32 +0000, bje wrote:

Quote:
There were probably other companies but Yamaha had several in the
"Natural Sound" series (that name is probably generic) that had motor
driven mechanical remote-controled volume controls.

They also were lopsided with weight balance.


got to be a Pioneer shirley? They made some massive knobs with lights
that wekt around but usually never in black.

Cursitor Doom
Guest

Sat Nov 09, 2019 1:45 pm   



On Sat, 09 Nov 2019 12:28:35 +0000, Cursitor Doom wrote:

Quote:
On Sat, 09 Nov 2019 11:22:26 +0000, Mike Coon wrote:

I still have my JVC amp/receiver/cassette with rotating & flashing
volume control. But clearly not the same as your recollection!

JVC certainly rings a bell... But this was only an amplifier.


And on the one I had, the LED was a different colour (green IIRC).



--
This message may be freely reproduced without limit or charge only via
the Usenet protocol. Reproduction in whole or part through other
protocols, whether for profit or not, is conditional upon a charge of
GBP10.00 per reproduction. Publication in this manner via non-Usenet
protocols constitutes acceptance of this condition.

Cursitor Doom
Guest

Sat Nov 09, 2019 1:45 pm   



On Sat, 09 Nov 2019 11:22:26 +0000, Mike Coon wrote:

Quote:
I still have my JVC amp/receiver/cassette with rotating & flashing
volume control. But clearly not the same as your recollection!


JVC certainly rings a bell... But this was only an amplifier.




--
This message may be freely reproduced without limit or charge only via
the Usenet protocol. Reproduction in whole or part through other
protocols, whether for profit or not, is conditional upon a charge of
GBP10.00 per reproduction. Publication in this manner via non-Usenet
protocols constitutes acceptance of this condition.

Martin Riddle
Guest

Sat Nov 09, 2019 2:45 pm   



On Sat, 9 Nov 2019 09:51:31 -0000 (UTC), Chris <cbx_at_noreply.com>
wrote:

Quote:
Hi all,

Without venturing into 'stupid money territory' the best quality audio by
far I've ever heard came from one particular solid state stereo amplifier
I'd be interested in re-acquainting myself with. Unfortunately I can't
recall the make or model number which is obviously a big barrier to the
desired reunion. However, if I mention some scant details I *do* remember
about it, maybe it will jog someone's memory.
What I _do_ recall is the following:-

It wasn't a Technics branded amp but neither was it one of the budget
brands.
It wasn't of European manufacture (I'm pretty sure it was Japanese).
It was the standard "separates" size of the late eighties/early nineties
and I owned one briefly 16 years ago so it can't be any later than 2003
and probably much earlier.
It had an all black finish.
It was only 60W per channel but punched above its weight in this respect
and produced _the_ most outstanding sound quality.
It was massively heavy on one side so must have had a _very_ substantial
transformer for such a relatively low power amp.
It had an unusual (and very cool) feature I'd never seen before or since
which hopefully will identify it: a quite small volume knob with a little
red LED on one edge of it which lit-up and physically rotated whenever
the remote control unit's volume button was activated.

Does that ring any bells with anyone? I wouldn't mind trying to find
another one!


Crown had made some low THD amps back in the 80's
I had a summer gig at Picker, that used them to test position
transducers.

Cheers

Dan Green
Guest

Sat Nov 09, 2019 3:45 pm   



On Sat, 09 Nov 2019 07:46:17 -0500, Martin Riddle wrote:

Quote:
Crown had made some low THD amps back in the 80's I had a summer gig at
Picker, that used them to test position transducers.


Any other pointless reminiscences you'd care to share?

Robert Baer
Guest

Sat Nov 09, 2019 11:45 pm   



Chris wrote:
Quote:
Hi all,

Without venturing into 'stupid money territory' the best quality audio by
far I've ever heard came from one particular solid state stereo amplifier
I'd be interested in re-acquainting myself with. Unfortunately I can't
recall the make or model number which is obviously a big barrier to the
desired reunion. However, if I mention some scant details I *do* remember
about it, maybe it will jog someone's memory.
What I _do_ recall is the following:-

It wasn't a Technics branded amp but neither was it one of the budget
brands.
It wasn't of European manufacture (I'm pretty sure it was Japanese).
It was the standard "separates" size of the late eighties/early nineties
and I owned one briefly 16 years ago so it can't be any later than 2003
and probably much earlier.
It had an all black finish.
It was only 60W per channel but punched above its weight in this respect
and produced _the_ most outstanding sound quality.
* Up to this point, that reminds me of a Sansui system i had ages ago.


Quote:
It was massively heavy on one side so must have had a _very_ substantial
transformer for such a relatively low power amp.
It had an unusual (and very cool) feature I'd never seen before or since
which hopefully will identify it: a quite small volume knob with a little
red LED on one edge of it which lit-up and physically rotated whenever
the remote control unit's volume button was activated.
* Now major description departure; sorry.


Quote:

Does that ring any bells with anyone? I wouldn't mind trying to find
another one!


Chris
Guest

Sun Nov 10, 2019 1:45 am   



On Sat, 09 Nov 2019 14:36:15 -0800, Robert Baer wrote:

> * Up to this point, that reminds me of a Sansui system i had ages ago.

No, it wasn't Sansui nor Sanyo nor Sharp nor Pioneer nor Proton as Phil
suggested, none of those nor any of the earlier ones in the thread people
said it might be. I guess I'll probably never know now it's just too long
ago. :(

Thanks for trying to assist, anyway guys.


Guest

Sun Nov 10, 2019 4:45 am   



On Saturday, 9 November 2019 23:59:06 UTC, Chris wrote:
Quote:
On Sat, 09 Nov 2019 14:36:15 -0800, Robert Baer wrote:

* Up to this point, that reminds me of a Sansui system i had ages ago.

No, it wasn't Sansui nor Sanyo nor Sharp nor Pioneer nor Proton as Phil
suggested, none of those nor any of the earlier ones in the thread people
said it might be. I guess I'll probably never know now it's just too long
ago. :(

Thanks for trying to assist, anyway guys.


google imagines for japanese amp doesn't get you anything?

Phil Allison
Guest

Sun Nov 10, 2019 4:45 am   



tabb...@gmail.com wrote:

------------------------
Quote:

google imagines for japanese amp doesn't get you anything?


** Might as well Google "cat" and select images in order to find your missing one.


..... Phil

Chris
Guest

Sun Nov 10, 2019 2:45 pm   



On Sat, 09 Nov 2019 18:46:24 -0800, tabbypurr wrote:

> google imagines for japanese amp doesn't get you anything?

Er, no........

Goto page 1, 2  Next

elektroda.net NewsGroups Forum Index - Repair Electronics - OT: Anyone remember this vintage audio amp?

Ask a question - edaboard.com

Arabic version Bulgarian version Catalan version Czech version Danish version German version Greek version English version Spanish version Finnish version French version Hindi version Croatian version Indonesian version Italian version Hebrew version Japanese version Korean version Lithuanian version Latvian version Dutch version Norwegian version Polish version Portuguese version Romanian version Russian version Slovak version Slovenian version Serbian version Swedish version Tagalog version Ukrainian version Vietnamese version Chinese version Turkish version
EDAboard.com map