EDAboard.com | EDAboard.eu | EDAboard.de | EDAboard.co.uk | RTV forum PL | NewsGroups PL

ADC_DAC_PGA_SPI_INTERFACE

Ask a question - edaboard.com

elektroda.net NewsGroups Forum Index - VHDL Language - ADC_DAC_PGA_SPI_INTERFACE

khuda Bakhsh Rai
Guest

Wed Oct 12, 2016 1:27 pm   



HELLO,
i have written a vhdl code of on chip adc,dac,pga on spartan 3e kit. code is working good.but when i applied ac input signal at the input then output of dac is clipped. can anyone help me out to resolve this issue.

KJ
Guest

Wed Oct 12, 2016 5:46 pm   



On Wednesday, October 12, 2016 at 7:27:25 AM UTC-4, khuda Bakhsh Rai wrote:
Quote:
HELLO,
i have written a vhdl code of on chip adc,dac,pga on spartan 3e kit. code is working good.but when i applied ac input signal at the input then output of dac is clipped. can anyone help me out to resolve this issue.


Either cut down the AC input signal voltage or increase the reference voltage. In short, verify that the input signal stays within the range that it is supposed to.

In the future, you might also want to post to a forum that is more relevant to your problem.

Kevin Jennings

rickman
Guest

Thu Oct 13, 2016 2:33 am   



On 10/12/2016 11:46 AM, KJ wrote:
Quote:
On Wednesday, October 12, 2016 at 7:27:25 AM UTC-4, khuda Bakhsh Rai wrote:
HELLO,
i have written a vhdl code of on chip adc,dac,pga on spartan 3e kit. code is working good.but when i applied ac input signal at the input then output of dac is clipped. can anyone help me out to resolve this issue.

Either cut down the AC input signal voltage or increase the reference voltage. In short, verify that the input signal stays within the range that it is supposed to.

In the future, you might also want to post to a forum that is more relevant to your problem.


What's wrong with this group? What group should he post in?

--

Rick C


Guest

Thu Oct 13, 2016 9:23 pm   



W dniu środa, 12 października 2016 13:27:25 UTC+2 użytkownik khuda Bakhsh Rai napisał:
Quote:
HELLO,
i have written a vhdl code of on chip adc,dac,pga on spartan 3e kit. code is working good.but when i applied ac input signal at the input then output of dac is clipped. can anyone help me out to resolve this issue.


Without the details about the AC signal,DAC and your code, nobody could be able to help you in this matter here.

Michael Kellett
Guest

Fri Oct 14, 2016 7:07 pm   



khuda Bakhsh Rai:
Quote:
HELLO,
i have written a vhdl code of on chip adc,dac,pga on spartan 3e kit.

code is working good.but when i applied ac input signal at the input
then output of dac is clipped. can anyone help me out to resolve this
issue.

You don't explain enough to help except in the most general terms.

Your DAC might be clipping because the digital signal is clipped or your
power supplies are at fault.
Mod your vhdl to make ramp driving the DAC from max to min and see what
that looks like - if good then your signal from the ADC must be
clipped.
Check that max adc signal is OK for the DAC.
Add some more test code to capture the maximum and minium digital codes
from the ADC (I often use a UART implemneted on the FPGA for this) -
then drive the ADC with signals.

Next time design your FPGA with test modes built in from the outset. I
pretty much never have an ADC without there also being a test mode
where I can substitute patterns for its data.

MK

elektroda.net NewsGroups Forum Index - VHDL Language - ADC_DAC_PGA_SPI_INTERFACE

Ask a question - edaboard.com

Arabic versionBulgarian versionCatalan versionCzech versionDanish versionGerman versionGreek versionEnglish versionSpanish versionFinnish versionFrench versionHindi versionCroatian versionIndonesian versionItalian versionHebrew versionJapanese versionKorean versionLithuanian versionLatvian versionDutch versionNorwegian versionPolish versionPortuguese versionRomanian versionRussian versionSlovak versionSlovenian versionSerbian versionSwedish versionTagalog versionUkrainian versionVietnamese versionChinese version
RTV map EDAboard.com map News map EDAboard.eu map EDAboard.de map EDAboard.co.uk map